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Working with Masks for Edge and Frame Effects 
This tutorial focuses on creating a Mask for your image, where the edges of your image will be masked by 
the custom shape of your choice. This gives the effect of the edges of the photo becoming invisible and 
taking on the shape of your custom frame. Before you begin, you will need to create a grayscale Mask or 
use one of my custom shape frames found on the CD. There are a few different ways you can create a 
mask in Photoshop. This technique will create a layer mask in order to achieve the desired effect. 
 
Incidentally, this method is how most edge software such as “AutoFX Photo/Graphic Edges”, and 
Extensis “Photographic Edges” works. They purport to offer you a huge supply of frames, in some cases 
upwards of 10,000 frames, when in fact they are supplying you with 10,000 masks to manipulate. In all 
honesty I really don’t see the point. In addition, many of the masks found in these expensive software 
programs look exactly the same, and are very limited in what range of effects can be applied to them. 
 
Once you learn the following masking techniques, and how these flexible masks can be applied and 
manipulated in Photoshop, you will soon see how quick and easy it is to create the exact same effects 
found in these other software packages. You will also realize that you have far greater control working 
within Photoshop than in any other third-party software. If you’re like me, you’ll wonder why you ever 
spent the money on these software packages in the first place. 

Creating an Edge Mask 
First, Create the custom shape mask. Alternately (and for a more flexible mask that can be used in 
virtually any Graphic program), you can create a blank .JPG image that is solid white, and paint in the 
frame edges with any of the 256 shades of gray. Though this frame can later be scaled to fit the 
dimensions of the image to which it will be applied, it is usually a better idea to create a shape or jpg the 
same dimensions ad the image. This way there is no need to scale the frame later, and it ensures the frame 
will look exactly the way you created it. The following will show you a quick way to create both: 
 
First, create a new document in Photoshop that is the same size as the image for which the mask will be 
applied. In this case, I am creating a mask that is 400x400 pixels at 72ppi. Be sure to select white for the 
Background color. Also, select Grayscale as the color mode. This will keep your file size down, and make 
sure that you create your edge with only the available 256 shades of gray. 
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Double-click on the Background layer and click OK in the dialog that pops up. This will convert your 
Background layer to a normal Layer (Layer 0) in Photoshop. This is necessary in order to select the mask 
in a later step. 
 
Now, create a new layer by clicking on the New layer icon in the Layers palette, and a new layer is placed 
above the white layer. 
 
Next, on this new layer, create the edges in any way you like. For this example, I used a scatter brush to 
paint an edge all the way around the image. It’s a good idea to make sure the edges go completely black 
towards the outer edges of the document, otherwise the image will show through later when we apply the 
mask to the image. 
 

 
 
When you are working to create your edge in the document, it’s a good idea to keep the following in 
mind: Black will hide the image, and white will reveal it. Any shade in between the two will act like an 
opacity setting, showing or hiding the image to a varying degree. If you apply 50% gray (128 
Red/Blue/Green), the image will be only 50% visible. 
 
In this way, the white at the center of the image produces an Opaque center (the image will show in the 
middle), and the frame which is made up of various shades of gray (up to 255 or black) will end up 
producing a transparent frame masking or hiding the image. 
 
At this point, why don’t we go ahead and save this as a JPG image on your hard drive somewhere. This is 
going to be our JPG mask. Once you have done this, follow the rest of the steps in this tutorial to also 
create the Custom Shape. 
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Going back to our image layers, once you have your edge created, Ctrl+click on the Edge layer. This will 
select the painted portion of the mask. 
 

 
 
Next, go into the Paths palette and click the Make Work Path from Selection icon in the Paths palette. 
Your selection is converted to a Path. 
 

 
 
Once you have the path selected, go into Edit  Define Custom Shape, and provide a name for your 
new shape edge. Click OK. You now have a custom Shape Edge that can be applied over the image. 
 

 
 

Masking the Image 
In the next part of this tutorial, I’ll show you how to apply the Custom Shape or JPG mask to your image, 
and how you can manipulate it endlessly in Photoshop. 
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Masking the Image with a JPG Mask 
Truth be told, you can take any grayscale image and use it as a mask, however, in order to create cool 
looking edge effects, edge masks are one of the best ways to go. So in a few simple steps let’s turn our 
edge mask into a masterpiece image frame. 
 
First, open a photo and the mask you want to apply to it. Then go into the image. If this image is on a 
background layer, double-click on the layer and click OK in the dialog that opens. This will convert the 
layer to a normal layer. If the image has multiple layers, first flatten the image before converting to a 
normal layer. 
 

 
 
Once the image is situated on it’s own layer, create a new layer and place it below the image layer. This 
can be any color/pattern/layer you like. This bottom layer is what we will mask the image over, or in other 
words, this layer will be used for the transparency. Anything that is masked out of the image around the 
edges will show through to this bottom layer. 
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In this example, I am going to make the bottom layer pure white by going into Edit -> Fill and selecting 
Use: White. But you are not limited by using only white. The bottom layer is fully editable by you and 
your imagination. 
 

 
 
Now go back to the mask document. If necessary, rotate the mask so it is the same orientation as the 
photo (Image > Rotate Canvas) or make the mask the same size as the photo (Image -> Image Size). If 
you have been following along with my previous tutorials, the mask is already the same dimensions as the 
image. 
 
Still within the Mask image, Select the entire image using Ctrl+A and Copy it to the clipboard using 
Ctrl+C. 
 
Go back to the image document and create a new Channel in the Channels palette. Then paste the mask 
into the new channel using Ctrl+V. When you have the Channel created, Ctrl+click on the new Channel 
to make it an active selection. You’ll see the marching ants scurrying around the black edge. 
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Next, while the channel selection is still active, go into the Layers palette (be sure that the image layer is 
highlighted), and click the Add Layer Mask icon at the bottom of the Layers palette. 
 

                
 
This creates a Layer Mask that erases the image through to the bottom layer. You now have an edge mask 
around your image. 
 

 
 

Masking the Image with a Custom Shape 
Masking an image with a custom shape is very similar to Masking with a JPG, however, the process is a 
little easier. Here are the steps: 
 
First, open the image to be masked. There is no need to open the Mask itself, as it is a Custom Shape 
within Photoshop. 
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If the image is on a background layer, double-click on the layer and click OK in the dialog that opens. 
This will convert the layer to a normal layer. If the image has multiple layers, first flatten the image 
before converting to a normal layer. 
 
Once the image is situated on it’s own layer, create a new layer and place it below the image layer. This 
can be any color/pattern/layer you like. This bottom layer will act as the background canvas, where the 
Custom Shape will mask out the image and reveal this backing layer. In this example, I am going to make 
the bottom layer pure white by going into Edit -> Fill and selecting Use: White. But you are not limited 
by using only white. The bottom layer is fully editable by you and your imagination. 
 

 
 
Next, go into the Layers palette (be sure that the image layer is highlighted), and click the Add Layer 
Mask icon at the bottom of the Layers palette. This creates a blank layer mask for the Image. 
 

                
 
Once you have the Layer Mask, expand the borders of the document window a little so you can see the 
entire image on-screen. If you need to, zoom out until you see the entire image. 
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Now select the Custom Shape Tool in the Toolbox, and on the option bar, click on the drop-down arrow 
to access the appropriate Custom Shape edge. 
 

         
 
Begin by clicking and dragging the shape from the top-left corner and drag diagonally down to the lower 
right corner. Then let go of the mouse. This creates a Layer Mask that erases the image through to the 
bottom layer. Don’t worry too much about the exact placement of the mask, as we will deal with that next. 
 

 
 
Sometimes when you perform this last step, you don’t always get the mask exactly where you want it to 
be. This is not a problem. You could do one of two things. First, you can undo what you just did and try to 
re-place the Custom Shape over the image. Or, you can use the trick that I always use in situations like 
these. 
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First, click on the link between the layer and the mask. This is found on the image layer in the layers 
palette between the image and the mask thumbnail. If you click here, this turns off the link between the 
two. Now you are free to transform the mask as you would any other layer. 
 

               
 
 
 
 
 
In the image at right, I am scaling the frame visually (using Edit -> 
Transform -> Scale). Notice how only the mask is moving, while the 
image stays locked in place. If the link were enabled between the two, 
both would be scaled simultaneously. 
 
 
 

 
 
 
 
When you are satisfied with your changes, accept the 
transformations (by clicking the green checkmark in the 
options bar) and don’t forget to click between the image 
and mask thumbnail once again to return the link between 
the two. As a general rule of thumb it’s better to keep these 
two items linked. But as you’ve seen, there are always 
special circumstances. The following shows our final 
mask: 
 
 
 
 
 
 

 
This is just the tip of the iceberg. With these 3 little layer items (image, layer mask, bottom canvas layer) 
you can distort and create a million different edge effects without altering the image data at all. Try doing 
that with “AutoFX Photo/Graphic Edges”. I guarantee that if you do, you will lose your image data, and 
in the process the ability to revert and go back to your original image easily. With this approach, 
everything is contained within the layer mask. 
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So at this point I’m sure you are wondering what is the best approach to masking your images? JPG, 
Custom Shape, or even using a Brush? Well, it really depends on what you want to accomplish. They all 
have positives and negatives. My personal preference is to use a JPG image because it tends to give you 
the best overall image and is the most flexible as it can be used within almost any graphics program. On 
the other hand, a Custom Shape is much more easily scaleable (being a vector graphic) on the positive 
side. On the negative side, a Custom Shape is unique to Photoshop, and does not translate over to other 
graphics applications like Paint Shop Pro. Both, however, are legitimate ways to create your frames and 
edges. The deciding factor will most likely be the graphics application you are using. If you have 
Photoshop, then you can use both. If you are planning to use any other graphics program, then the best 
solution would be a JPG Mask. 
 
In the next tutorial we’ll explore some quick and easy ways to alter your new Image edge. 
 

Mask Alterations 
So far we’ve looked at how to create a Custom Shape and JPG Mask, and how to apply that to an Image. 
We even touched on a minor alteration to the mask, by Scaling it to fit the image. But with the Mask 
applied to the image, the edge is still very simple and very plain. There is no oomph. So let’s see what we 
can do to add a little pizzazz and flare. In the following exercise, we’ll look at how to apply a wide range 
of effects to the edge in order to enhance or improve upon the framing. And the beauty of it is that we 
won’t change a thing in our image. The image is completely unaffected. 
 
Before I jump right in with both feet, let’s try to take a step back and look at the big picture. Rather than 
show you very specific recipes for custom edge effects, I think it might be more beneficial to take a 
general approach and show you some of the groups of things that can be done to change your edges. In 
my mind these are the 5 main things that will give you the most bang for your buck when working on 
these edges: 
 

1. Transformations 
2. Filters 
3. Styles 
4. Tone and Texture 
5. Color 

 
If you approach your edges in this manner, you can open yourself up to a world of possibilities that no 
AutoFX package can beat. Furthermore, what I want you to do is this. Think about the layer mask as 
nothing more than an image layered on top of your other image. When you look at it this way, you begin 
to understand that you can affect the mask in almost any way that you could affect the image. So let’s 
look at each one individually: 
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1. Mighty Morphing Masks: Transformations 
 

I’ve already touched on Transformations in the previous tutorial, and I think you get the idea that 
you can use the link between the mask and the layer to cut off the circulation between the two. 
This allows you to scale, distort and transform the mask in any way you like. But did you also 
know that you could Use all the filters under Filters -> Distort to change the appearance of a mask 
as well? Try Twisting or Shearing the mask slightly and you can come up with some very 
satisfying results. Note that in the examples to follow, I changed the bottom canvas layer to black, 
which shows off the effect in a more pronounced way here: 

 
Filter -> Distort -> Pinch x2 and 50% Fade: 

 

 

Filter -> Distort -> Ocean Ripple: 
 

 
 

2. Grab the filter, This pot of coffee is brewing. 
 

Next up, we have access to every filter that ships with Photoshop. Not only that, but how about the 
ability to stack filters one on top of the other ad-infinitum? And in an endless combination and sea 
of settings. Well, I think you get the idea. 
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One other important thing to note is that if you look at the images below, you’ll see that many of 
the filters have interactive dialogs where you can see the effect applied to the image in real-time 
both in the dialog and in the image itself. This is far superior to any third party software in my 
opinion. To make these kinds of changes on this level provides an amazing precision and control 
over what is occurring to your edges. Here are a few variations: 

 
Filter -> Blur -> Gaussian Blur: 

 

 
 

Filter -> Sharpen ->Sharpen Filter: 
 

 
 

Filter -> Texture -> Texturizer (Sandstone): 

          
 

Note: To achieve the effect on the right, before applying the filter you must hold your mouse over the 
Layer Mask and Ctrl+click on the mask. Then invert the selection using Ctrl+Shift+I or Select -> 

Inverse. Otherwise, you will apply the Sandstone filter to the entire image (shown above left). This way, 
you apply the textured filter to the edge mask only (shown above right). 

 

Copyright © 2005 http://www.chainstyle.com/ Robert Anselmi All rights reserved. This document is not to be copied, reproduced, 
redistributed, or sold in part or in whole by any means without prior written consent from the author. Violation of this copyright is 
enforceable by local, state, and/or federal laws. All other company names, trademarks, and registrations are the property of their respective 
owners. 



Page 13 of 16 

3. What up! These Kickin’ Edges are Stylin’ 
 

Probably the most common and well-known ways to affect a layer is to add a Layer Style to the 
image. You can do the same thing to apply the style to the layer where the Image and Layer Mask 
are situated. As Long as you have the “Transparency Shapes Layer” checkbox turned on (don’t 
worry, it is by default), then you will see the style applied to the mask. A very handy feature 
indeed. Just double-click the layer to access the plethora of Styles available. Or click on the Layer 
Style icon at the bottom of the Layers palette and choose your poison. Here are a few examples: 

 
Adding a Bevel & Emboss Style: 

 

 

Adding a Stroke and Inner Shadow Style: 
 

 
 

4. Can you feel it? Can you feel the Texture? 
 

We already took a quick look at the texture option when we saw a glimpse of the Sandstone filter 
(above). Well, you don’t need to stop there. You can add any kind of textured effects via 
Channels, Lighting Effects under the Filter Menu, Gradients, and an assortment of Displacement 
Maps and Bump Maps, just to name a few. While explaining all of these concepts is a bit beyond 
the scope of this document, the idea is to experiment with the edges and see what works and what 
doesn’t. You’re bound to run into some very original thinking and original ideas. And that is 
invaluable. 

 
5. There’s no Black and White when it comes to Layer Masks 

 
Well, ok maybe there is. By their nature, a mask is simply a way to adjust the opacity of the layer 
it’s tied to. In that sense there are only 256 shades of gray (0-100% opacity/transparency). But 
there’s a trick that we’ve built into our masks that defies this logic. We have a whole other layer 
under our image to play with, and this layer DOES accept more than just 256 shades of gray. 
Remember that white layer I placed under the image? Well if you recall, I told you that this layer 
could contain any color, pattern, texture, image, etc. that you want. And this is our secret weapon. 
The layer to defy all masking color logic: The background canvas. 
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Earlier I changed the color of the bottom layer to black. But the fun doesn’t stop there. Throw in a 
pattern or two, or even a gradient, as shown below. Simply select the bottom layer and manipulate 
it at will. 

 
Gradient applied to bottom layer: 

 

 

Nature Pattern applied to bottom layer: 
 

 
 
By now I hope you can see the advantages to working on Layer Masks for edge effects. Trust me, you 
don’t need any additional software installed on your machine in order to make the effects you see here. A 
few simple steps can create some fantastically stunning effects. So jump in and try it out for yourself. I’m 
willing to bet you won’t be able to take yourself away from the computer once you get started. 

Converting Masks for use in Other Programs 
This is all fine and dandy if you want to create your Custom Shapes or JPGs from scratch, but what if all 
you have is the Custom Shape or an alternate photo masking software such as AutoFX Photo/Graphic 
Edges. In other words, what if you want to convert all of these great masks from other sources into a JPG 
so that you can use them in alternate graphic programs. Well, here are a few techniques you can use: 
 
Keep in mind that most programs allow you to use a grayscale mask in one way or another. And the 
easiest way to do this is to create a JPG file that can be exported/imported between programs. While 
explaining the methodologies and techniques for masking in other programs is beyond the scope of this 
document, I can at least get you to the point where you have your JPG mask. 
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Converting a Custom Shape to a JPG mask 
First, create a new Grayscale document that is the same size and resolution of the mask. Make sure to set 
the background to white, ensuring that the new document will be filled with a white background. 
 

 
 
Next, select the default black/white foreground/background colors. This will ensure that when the custom 
shape is placed into the document, it will be black. 
 

 
 
Expand your window view so that you can clearly see the edges of your new document, and leave space 
on all sides. This is done, in case you want to extend the frame beyond the boundaries of the document 
(thereby creating a partial frame inside the document and outside the document bounds). 
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Lay down the custom shape so that it frames the new document, and encompasses the edges. 
 

 
 
Save the document as a JPG image (the document will be flattened and saved in the JPG format). You can 
now use this JPG mask in most other graphic applications, such as “Paint Shop Pro” and “Painter”. 
 

Converting Hard-to-Get Masks 
Lastly, there are some programs that play hard-to-get. That is, you can’t find a way to extract them easily. 
In these circumstances I can only recommend two things. First, you could apply the Edge mask to a 
dummy image, then select the transparency of the layer and save the selection. Then open a new 
document the same size and apply the selection to that document. Once you have the selection, you can 
fill it with black and save this document as a JPG file. 
 
The second way is to find some way to access the software’s catalog, and use the archaic “Print Screen” 
key. By doing this, you are in effect copying whatever is on your screen to the clipboard. Then when you 
go into photoshop and click on File -> New, a document will be created the same size as the screen grab 
you took. Simply paste the screenshot into this new document, and crop the image to the size of the edge 
frame. Voila. Instant Mask. 
 
My apologies to you MAC users. I am not sure if you guys have a “Print Screen” key or if you can follow 
this same procedure, but if not, you can also utilize a screen capture software such as “SnagIt” by 
TechSmith software. I’ve been using their screen capture software for years, and can say they are one of 
the best out there. 
 
I hope this has provided you with some useful information. 
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